Translate

Thursday 7 August 2014

Patching AIX from the command-line

Many people use SMIT when updating AIX and/or NIM but do not realise that they can also do this from the command-line using two IBM-supplied sctripts. Patches downloaded from Fix Central should all be in one directory e.g. "6100-08-02-1316".

Change to the directory containing the patches and ensure that it is writeable, so inutoc can create/update the index, all that the files are readable by root.

# cd 6100-08-02-1316
# inutoc .

Run the patch-install script:

# install_all_updates -d . -Y

+-----------------------------------------------------------------------------+
                                Summaries:
+-----------------------------------------------------------------------------+

Pre-installation Failure/Warning Summary
----------------------------------------
Name                      Level           Pre-installation Failure/Warning
-------------------------------------------------------------------------------
sysmgt.websm.rte          6.1.7.1         Requisite failure
sysmgt.pconsole.rte       6.1.7.2         Requisite failure
perfagent.tools           6.1.7.2         Requisite failure
devices.vdevice.IBM.v-scs...

...

 The results will not only be displayed on the screen but stored in "/var/adm/ras/install_all_updates.log".

You now reboot your system to ensure everything is working OK and once satisfied you can commit all the newly applied fixes in order to remove the old copies and save a lot of space in "/usr".

# installp -c ALL
# oslevel -s
6100-08-02-1316

If you are using NIM you will also want to update your LPP_SOURCE so that any new clients will be built to the same OS level. Fortunately this can also be done from the command-line:

Note: NIM can only be patched this way to TL (tech-levels) and not SP (Service Packs).

# cd <patch-directory>
# nim_update_all -d . -s 610spot_res -l 610lpp_res -v -u
+ typeset +f
+ typeset -ft DEBUG
+ typeset -ft _check_level
+ typeset -ft bname
+ typeset -ft check_access
+ typeset -ft check_cpush_ok
+ typeset -ft check_level
+ typeset -ft check_push_ok
+ typeset -ft ck_attrs
+ typeset -ft ck_gencopy_flags
+ typeset -ft ck_inst_root_dirs
+ typeset -ft ck_installp_flags
+ typeset -ft ck_rel_level
+ typeset -ft ck_spot_options
+ typeset -ft cleanup
+ typeset -ft cmd_what
+ typeset -ft convert_arch_value
+ typeset -ft create_sysb
+ typeset -ft err_from_cmd
+ typeset -ft err_signal
+ typeset -ft error
...

..
395266 of 422959 files (93%)....................

0512-003 mksysb may not have been able to archive some files.
The messages displayed on the Standard Error contained additional
information.
+ [[ 0 -ne 0 ]]
+ return 0
+ [ 0 -ne 0 ]
+ /usr/bin/tee -a /var/adm/ras/nim.update
+ /usr/bin/dspmsg -s 2 cmdnim.cat 338 \nNIM update_all is complete - enjoy!

NIM update_all is complete - enjoy!

Your SPOT and LPP_SOURCE should now be at the same level.

# lsnim -l 610spot_res

610spot_res:
   class         = resources
   type          = spot
   plat_defined  = chrp
   arch          = power
   Rstate        = ready for use
   prev_state    = verification is being performed
   location      = /export/eznim/spot/610spot_res/usr
   version       = 6
   release       = 1
   mod           = 8
   oslevel_r     = 6100-08
   alloc_count   = 0
   server        = master
   Rstate_result = success
   mk_netboot    = yes
   mk_netboot    = yes
   mk_netboot    = yes


No comments:

Post a Comment